解决Gradle4.1报错:Could not determine java version from '9.0.1'.

执行

react-native run-android

gradle版本: 4.1
jdk:9.0.1

报错:

Starting JS server...
Building and installing the app on the device (cd android && ./gradlew installDebug)...

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine java version from '9.0.1'.

解决方法:

升级到最新版本Gradle 4.3-rc-2可以解决。

找到项目的gradle-wrapper.properties文件,路径如下

PROJECT_PATH/android/gradle/wrapper/gradle-wrapper.properties

distributionUrl修改如下:

distributionUrl=https\://services.gradle.org/distributions/gradle-4.3-rc-2-all.zip

版权声明:著作权归作者所有。

相关推荐

npm报错解决:Error: ENOSPC, write

在Linux使用npm安装mongodb报了ENOSPC的错误,错误信息:# npm install mongodb npm http GET https://registry.npmjs.org/mongodb npm http 200 https://registry.npmjs.org/mongodb