Android Studio 3.0报错:Error:android-apt plugin is incompatible with the Android Gradle plugin. Please use 'annotationProcessor' configuration instead.

Android Studio 3.0执行android-apt报错:

Error:android-apt plugin is incompatible with the Android Gradle plugin.  Please use 'annotationProcessor' configuration instead.

原因及解决

Android Gradle 2.2插件集成了android-apt里的所有功能,从Android Gradle 2.3插件开始阻止android-apt的使用。同时android-apt官方停止维护,建议迁移到annotationProcessor。具体查看apt迁移通知From apt to annotationProcessor

迁移方法

1、在build.gradle添加Android Gradle 3.0 插件

buildscript {
    repositories {
        ...
        google()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.0'
    }
}

2、删除build.gradle里android-apt 的相关配置

 buildscript {
     repositories {
         ...
      google()
     }
     dependencies {
         classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8'
     }
 }
 apply plugin: 'com.neenbedankt.android-apt'

3、替换build.gradle里旧的配置为新的配置

做以下替换

  • compile 改为 implementation,
  • apt 改为 annotationProcessor  
  • testCompile 改为 androidTestImplementation

 dependencies {
   compile 'com.google.dagger:dagger:2.0'
   apt 'com.google.dagger:dagger-compiler:2.0'
 }

改为

 dependencies {
     implementation 'com.google.dagger:dagger:2.0'
     annotationProcessor 'com.google.dagger:dagger-compiler:2.0'
 }

4、清理缓存并重启Android Studio 3.0

版权声明:著作权归作者所有。

相关推荐