brew升级ruby错误处理:Xcode alone is not sufficient on Sierra.

使用brew升级ruby:

brew upgrade ruby

报错:

Error: Xcode alone is not sufficient on Sierra.
Install the Command Line Tools:
xcode-select --install 

如提示所说,安装ruby除了安装Xcode外,还需要安装Command Line Tools。

打开终端,输入命令:

xcode-select --install

确保安装成功:

xcode-select -p

出现"/Library/Developer/CommandLineTools" 路径即表示安装成功。

版权声明:著作权归作者所有。

相关推荐

卸载使用brew安装的mongodb脚本

这个用来卸载Mac使用brew安装的mongodb。#!/usr/bin/env sh # 检查mongo是否在运行中 launchctl list | grep mongo launchctl unload ~/Library/LaunchAgents/homebrew.mxcl.mongodb.plist launchctl remove homebrew.mxcl.mong

Ruby调用shell脚本总结

Ruby可以使用以下几种方法来执行shell脚本。1、使用反引号``调用shell脚本语法`cmd` 返回命令的结果示例`echo "hello"` 2、内置语法%x( cmd ) 其中%x后面为分隔符,上面使用了(作为分隔符,当遇到收括号即表示命令结束。这些分隔符可以为[,{等。示例%x( echo 'hello' 

Mac升级Ruby到最新版本

升级Ruby可以使用rvm和brew:rvm安装rvmcurl -sSL https://get.rvm.io | bash -s stable 列出ruby版本rvm list known 安装最新版本rvm install ruby-<latest-version> 查看ruby版本