Android Studio 3.1 Canary 3 :Gradle同步失败

Android Studio 3.1 Canary 3 执行gradle sync报错:

Gradle sync failed: com.android.tools.idea.gradle.project.model.AndroidModuleModel.getSelectedVariant()Lcom/android/tools/idea/gradle/project/model/ide/android/IdeVariant;

这是Kotlin插件1.1.60-release-Studio3.0-1的问题。

卸载Kotlin插件

Preferences > Plugins > Kotlin > Uninstall

使用旧版的kotlin插件1.1.51-release-Studio3.0-1解决此问题。

kotlin插件列表:https://plugins.jetbrains.com/plugin/6954-kotlin

版权声明:著作权归作者所有。

相关推荐

Android Studio 3报Error:CreateProcess error=216错误的两种情况

当配置的JDK版本和Android Studio 3所要求的JDK版本不符合时会报错误:CreateProcess error=216错误。它分为两种情况:情况一:配置的JDK版本低于JDK 8当配置的JDK版本低于JDK8会报类似以下的错误:Error:CreateProcess error=216, 该版本的 %1