在Windows使用pip安装报错:WindowsError: [Error 5] Access is denied:

在Windows下使用pip安装mitmproxy :

pip install mitmproxy

但是即使是以管理员身份运行cmd,仍然会报权限的错误:

WindowsError: [Error 5] Access is denied: 'c:\\users\\cc\\appdata\\local\\temp\\easy_install-safew\\cryptography-0.9.1\\.eggs\\cffi-1.1.2-py2.7-win-amd64.egg\\_cffi_backend.pyd'

解决方法

查找到的解决方法,以管理员打开cmd,然后执行以下命令:

python -m pip install mitmproxy

版权声明:著作权归作者所有。

相关推荐

CentOS 7安装pip3

首先要确保在CentOS 7上已经安装了EPEL仓库。如果没有安装,执行以下命令安装:yum install -y epel-release 安装后,安装pip3$sudo yum install python34-pip $pip3.4 install foo

Windows使用nvm-windows管理node.js多版本切换

nvm和n是两个在Mac/Linux上常用于管理node版本的工具,遗憾的是这两个工具都不支持Windows。在Windows可以用来管理Node版本的工具主要有:nvm-windows,nodist。本文主要介绍使用nvm-windows来管理node的版本。首先nvm-windows并非nvm的Windows版本,它是单独开发的用于在Windows管理Node版本的工具。nvm-window项